Onboard Ethernet FAQ

It boots very slowly-it takes about a minute and a half.

Note: The following no longer works because the cx89x0 code is compiled into the kernel. However, if should give you a hint about where to start.

The problem is that the Ethernet port on the board is timing out because it cannot find a DHCP server... The Stayton did not have an Ethernet port on board so it did not try to connect at boot time.

In the file /etc/init.d/networking comment out the modprobe line so it looks like this

# modprobe cx89x0

It is my understanding that this just disables the Ethernet port but not other networking operations. But I should really test this.

This is some results of some quick timing tests

Yes. That is the file. The lines to look for are commented in the net_open function call. There should be a comment saying "If the link is NOT OK bail out". If you uncomment those lines then the Ethernet driver should bail out if there is no link and avoid the large time out. Like I said if you uncomment the lines, the driver may become flaky so please test it. Also this was before the memory fix, may be it will work now.

I noticed this problem too. It appears that the cs89x0 driver doesn't have any code to adequately deal with 'link-down' situations. For example, a section of the 'net_open' routine that deals with link up-down situations is commented out. Thus, it basically assumes the link is always up..

Maybe we can get Donald Becker to fix it for us?? :)

I have observed that the bandwidth I get when transferring files to the Stargate is too low (160 KB/s). Isn't the NIC on the Stargate a 10MBPS card? Any clues on this.

When transferring the files, where are they being saved? If it's to the flash, then saving files will be flash-write limited, which is a fairly slow operation.

You can test this by trying to save the file to /tmp/ or /dev/null

The on-board NIC seems to be less than excellent. First, I can't get it to do more than half-duplex, and second, it's dropping packets right and left (sometimes 10%), which makes TCP go _really_ slow. I've tried different drivers, and messed with some of the card settings, to no avail. I think the problem might be that there's only a 2KB buffer in the NIC chip, which obviously overflows quite easily. Oftentimes, I've maxed out around 20KB/s. That's sending a file from my Apple PowerBook using scp to the stargate, over cross-over cable, hub or switch. PC's with Linux seem to do better, due to a more aggressive sending TCP implementation, I would guess.


If we hypothetically needed two ethernet ports on our starate, what are our options? (Wondering about the feasibility of a future project.) Both our cf/pcmcia slots are already filled - one with an 802.11 card, and one with external flash. Is there a way to put a 2nd daughter card on the stargate, or a daughter card with 2 ethernet ports? Or, will a future spin of the board perhaps have ethernet on board?

I have tested the Stargate with a Socket Comm low power Ethernet PCMCIA adapter. It works out of the box.

I tried a USB one (probably a Netgear model) but couldn't find the right Linux drivers easily.